【Next.js】Error: error:0308010C:digital envelope routines::unsupportedなエラー

Next.jsのプロジェクトでタイトルのエラーが出たので、ググると以下のページがヒットして

Next.jsでError: error:0308010C:digital envelope routines::unsupportedを直す方法 – magazine off

 

「Node.jsのバージョンを下げたら直るぞ」と書かれていたので、下げてみたら直りました。

原因は不明。

 

私の場合は、nvmでNode.jsのバージョン管理をしていたので、以下のコマンドでバージョンを切り替えるとエラーが発生しなくなりました。

nvm install 14.18.1

ちなみに切り替える前は、今現在の最新版であるv17.1.0を使っていました。

 

Linux
スポンサーリンク
この記事を書いた人
penpen

1991生まれ。
2019年くらいからフロントエンドエンジニアを目指している元アフィリエイターです💩

penpenをフォローする
penpenをフォローする
penpenメモ

コメント

タイトルとURLをコピーしました